Scheduled Maintenance
Incident Report for Buildium
Resolved
Buildium is once again available. Thank you for your patience.
Posted about 1 month ago. Dec 08, 2018 - 03:25 EST
Identified
Buildium will be unavailable between 12:00 AM and 4:00 AM ET tonight (12/8/2018), as we are conducting planned maintenance. We apologize for the inconvenience and thank you for your patience.
Posted about 1 month ago. Dec 07, 2018 - 17:35 EST