Phone Support Unavailable

Incident Report for Buildium

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 14:39 EDT

Identified

Our phone support provider is currently experiencing an outage. While we work with them to restore phone support, if you need assistance please email ticketsupport@buildium.com.
Posted Jun 10, 2025 - 11:27 EDT
This incident affected: Phone support.