Phone Support Down
Incident Report for Buildium
Resolved
Our phone support system is fully operational.
Posted Aug 26, 2021 - 16:25 EDT
Monitoring
Our Phone system has returned to operational status, we will continue to monitor.
Posted Aug 26, 2021 - 15:36 EDT
Identified
We are currently experiencing issues with our phone system. Please submit a support ticket by emailing ticketsupport@buildium.com. We are actively working on a solution, thank you for your patience.
Posted Aug 26, 2021 - 13:50 EDT
Investigating
We are currently experiencing issues with our phone system. Please submit a support ticket by emailing ticketsupport@buildium.com. We are actively working on a solution, thank you for your patience.
Posted Aug 26, 2021 - 13:48 EDT
This incident affected: Phone support.