Some Inbound Calls Not Connecting to Support
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Jun 24, 2021 - 11:59 EDT
Monitoring
Performance has been restored to our phone service. We are continuing to monitor for any remaining problems.
Posted Jun 24, 2021 - 11:35 EDT
Identified
Our phone support system is currently experiencing degraded performance. If you experience dead air, please hang up and try again. If you cannot connect, an agent will attempt to call you back. You may also email ticketsupport@buildium.com, and we will get back to you as soon as possible.
Posted Jun 24, 2021 - 11:07 EDT
This incident affected: Phone support.