Mobile and API slowness

Incident Report for Buildium

Resolved

This incident has been resolved.
Posted May 01, 2025 - 15:35 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 01, 2025 - 13:32 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 01, 2025 - 11:36 EDT

Investigating

You may be experiencing slowness in Buildium Mobile applications and the API. Our team is actively working to resolve this issue as quickly as possible.
Posted May 01, 2025 - 10:44 EDT
This incident affected: Buildium Platform (Open API, Buildium Manager Mobile App - iOS, Buildium Manager Mobile App - Android, Buildium Resident Center Mobile App - iOS, Buildium Resident Center Mobile App - Android).