Buildium performance issue
Incident Report for Buildium
Resolved
We're happy to report that all issues are resolved and all systems are now fully back online. Thank you again for your patience.
Posted about 1 month ago. Jan 14, 2019 - 08:53 EST
Monitoring
The technical difficulties we were investigating appear to be resolved. We will continue to monitor for further problems.
Posted about 1 month ago. Jan 14, 2019 - 08:09 EST
Investigating
Buildium is currently experiencing technical difficulties. We're actively investigating the issue and will update this page shortly.
Posted about 1 month ago. Jan 14, 2019 - 07:38 EST
This incident affected: Phone support.