Zuora Intermittent Performance

Incident Report for Buildium

Resolved

This incident has been resolved.
Posted Jul 31, 2024 - 18:12 EDT

Monitoring

The performance issues with our billing system, Zuora, have been resolved. You should now be able to make changes to your subscription and access billing reports.
Posted Jul 31, 2024 - 16:42 EDT

Update

We are continuing to investigate this issue.
Posted Jul 31, 2024 - 16:00 EDT

Investigating

Our billing system, Zuora, is currently experiencing performance issues. You may be unable to make changes to your subscription or access billing reports at this time. For more information, visit Zuora's status page: https://trust.zuora.com/incidents/l1pm8cjkh9ln
Posted Jul 31, 2024 - 15:57 EDT
This incident affected: Buildium Platform (Buildium Platform) and Buildium.com.