Login issue
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 10:05 EST
Monitoring
We have corrected the login issue. We are monitoring for any further issues
Posted Feb 06, 2024 - 09:28 EST
Identified
We have identified the issue and will correct login access. You will see a period of slowness in Buildium while we correct this issue.
Posted Feb 06, 2024 - 09:14 EST
Investigating
We are aware of a login issue for some clients using Google. We are actively looking to correct this issue. Please try to refresh the page on login to attempt access.
Posted Feb 06, 2024 - 08:44 EST
This incident affected: Buildium.com.