Scheduled Maintenance
Incident Report for Buildium
Resolved
Buildium is once again available. Thank you for your patience.
Posted about 1 year ago. Sep 17, 2017 - 00:02 EDT
Identified
Buildium will be unavailable between 9:00 PM and 12:00 AM EDT tonight, as we are conducting planned maintenance. We apologize for the inconvenience and thank you for your patience.
Posted over 1 year ago. Sep 16, 2017 - 16:17 EDT