Slowness Detected
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Feb 06, 2023 - 12:07 EST
Monitoring
We have identified the issue and have taken steps to restore access. You should see normal operations in the system, and we shall continue to monitor the issue.
Posted Feb 06, 2023 - 11:13 EST
Investigating
You may be experiencing slowness in Buildium. Our developers are working to resolve this as soon as possible.
Posted Feb 06, 2023 - 10:49 EST
This incident affected: Buildium Platform (Buildium Platform).