Site Slowness
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Sep 08, 2020 - 13:10 EDT
Monitoring
We have resolved what was causing potential slowness in Buildium accounts, and are continuing to monitor system performance.
Posted Sep 08, 2020 - 12:40 EDT
Investigating
You may be experiencing slowness in Buildium. We expect any slow performance to be resolved soon.
Posted Sep 08, 2020 - 12:20 EDT
This incident affected: Buildium Platform (Buildium Platform).