Application Slowness
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted 6 months ago. May 01, 2019 - 13:52 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 months ago. May 01, 2019 - 12:52 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 6 months ago. May 01, 2019 - 12:04 EDT
Investigating
We are currently investigating this issue.
Posted 6 months ago. May 01, 2019 - 12:02 EDT