Delay in processing scheduled ACH and Credit Card payments
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Mar 01, 2024 - 13:47 EST
Monitoring
All of the remaining scheduled ACH and Credit Card payments have been processed.
Posted Mar 01, 2024 - 13:22 EST
Update
We are continuing to work on processing remaining scheduled payments. We expect these payments to be processed in the next 30 minutes.
Posted Mar 01, 2024 - 12:32 EST
Update
We are continuing to work on processing all remaining ACH and Credit Card Payments. We currently expect all scheduled payments to be processed in the next hour.
Posted Mar 01, 2024 - 11:12 EST
Identified
We are investigating a delay in resident payment processing; please do not resubmit a payment; the system is adding payments in the order that they were submitted. We expect this process to take two more hours to process these items.
Posted Mar 01, 2024 - 09:34 EST
This incident affected: Buildium Platform (Online Payments).