Slowness in Buildium
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Mar 09, 2022 - 16:45 EST
Monitoring
We are no longer seeing slowness in Buildium accounts. We will continue to monitor performance to ensure this issue is fully resolved.
Posted Mar 09, 2022 - 16:10 EST
Investigating
You may be experiencing slowness in Buildium. Our developers are investigating, and we will update this message when we have more information.
Posted Mar 09, 2022 - 16:03 EST
This incident affected: Buildium Platform (Buildium Platform, Resident Center, Open API).