Phone Support Down
Incident Report for Buildium
Resolved
This incident is resolved.
Posted Feb 10, 2023 - 16:46 EST
Monitoring
Our phone provider has added mitigation measures in place, and we are seeing recovery with phone support.
Posted Feb 10, 2023 - 16:21 EST
Investigating
We are currently experiencing issues with our phone provider. At this time, please submit a support case for assistance. We apologize for the inconvenience and are working with our provider to resolve this issue as soon as possible. Need help? Submit a support ticket- https://help.buildium.com/hc/s/contactsupport
Posted Feb 10, 2023 - 16:01 EST
This incident affected: Phone support.