Buildium.com cannot be reached
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Jun 29, 2020 - 16:21 EDT
Monitoring
Our partner was able to release a fix for this issue, and users can now load Buildium.com without issue. Users can now also resume access to Buildium Academy.

We will continue to monitor the situation.
Posted Jun 29, 2020 - 14:52 EDT
Identified
We have currently identified and issue that is preventing users from loading the buildium.com site. If you are trying to log into your Buildium account, please go to https://signin.managebuilding.com/

Please note, you will not be able to access Buildium Academy during this time.

Please visit https://wpenginestatus.com/incidents/230748 for more information.
Posted Jun 29, 2020 - 11:31 EDT