System Maintenance
Incident Report for Buildium
Resolved
Maintenance has been completed
Posted Jun 03, 2020 - 14:16 EDT
Monitoring
Notice: You may be experiencing slowness in Buildium due to maintenance. We expect any slow performance to be resolved within the hour.
Posted Jun 03, 2020 - 13:36 EDT
This incident affected: Buildium Platform (Buildium Platform).