System Slowness
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 14:22 EDT
Monitoring
We have resolved the issue with intermittent slowness in Buildium. We will continue to monitor system performance to ensure the issue is fully resolved.
Posted Jun 01, 2020 - 13:16 EDT
Investigating
Notice: You may be experiencing slowness in Buildium. We expect any slow performance to be resolved soon.
Posted Jun 01, 2020 - 12:06 EDT
This incident affected: Buildium Platform (Buildium Platform).