2FA Code Delay

Incident Report for Buildium

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 18:03 EDT

Monitoring

We are observing recovery in SMS delivery delays and failures from our provider Twilio for multiple networks in the US. We are continuing to monitor the issue for updates.
Posted Aug 28, 2025 - 16:48 EDT

Identified

Some users may experience trouble accessing Buildium due to SMS delivery delays affecting 2FA codes across multiple U.S. networks. We are actively working with our partner, Twilio, to resolve the issue.
Posted Aug 28, 2025 - 15:21 EDT
This incident affected: Buildium.com.