Buildium performance issue
Incident Report for Buildium
Resolved
We're happy to report that all issues are resolved and all systems are now fully back online. Thank you again for your patience.
Posted over 1 year ago. Jun 28, 2017 - 13:10 EDT
Monitoring
The stability issues we were investigating appear to be resolved. We will continue to monitor for further problems.
Posted over 1 year ago. Jun 28, 2017 - 12:02 EDT
Investigating
Buildium is currently experiencing intermittent outages. We're actively investigating the issue and will update this page shortly.
Posted over 1 year ago. Jun 28, 2017 - 11:51 EDT