Site inaccessible for some
Incident Report for Buildium
Resolved
The stability issues we were facing are now resolved.
Posted Jun 02, 2017 - 11:30 EDT
Monitoring
The stability issues we were investigating appear to be resolved. We will continue to monitor for further problems.
Posted Jun 02, 2017 - 10:17 EDT
Investigating
We are seeing problems with the Buildium site. It has become unavailable for some people and we are currently investigating.
Posted Jun 02, 2017 - 09:02 EDT