Users Unable To Login to Buildium
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Jun 17, 2020 - 22:37 EDT
Monitoring
We have identified the cause of the inability to log in to Buildium, and you can now log in without issue. We will continue to monitor the situation.
Posted Jun 17, 2020 - 20:08 EDT
Investigating
We are aware of an issue that is preventing users from being able to sign into their Buildium accounts. We are investigating the issue.
Posted Jun 17, 2020 - 19:03 EDT
This incident affected: Buildium Platform (Buildium Platform).