We are experiencing an issue with phone support
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 13:35 EDT
Investigating
We are having an issue with our phone service provider, that may mean agents are not able to hear you, and vice versa. We are working with our service provider to resolve this issue as quickly as possible. While we work on this issue, please consider creating a support case, by emailing support@buildium.com.
Posted Apr 22, 2024 - 11:16 EDT
This incident affected: Phone support.