Buildium Slowness Detected
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted May 01, 2023 - 15:57 EDT
Monitoring
We have added a fix to correct this slowness and will continue to monitor this slowdown issue.
Posted May 01, 2023 - 14:50 EDT
Update
We have seen the slowness in Buildium be significantly reduced, but we are still looking into its cause to prevent further issues.
Posted May 01, 2023 - 13:35 EDT
Update
We are continuing to investigate the issue around slowness on page loads.
Posted May 01, 2023 - 13:10 EDT
Investigating
You may be experiencing slowness in Buildium. Our developers are working to resolve this as soon as possible.
Posted May 01, 2023 - 12:27 EDT
This incident affected: Buildium Platform (Buildium Platform).