Buildium Slowness

Incident Report for Buildium

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 16:28 EST

Monitoring

Slowness in the system has been addressed, and we shall monitor Buildium for any ongoing issues.
Posted Feb 03, 2025 - 16:07 EST

Identified

You may be experiencing some limited slowness in Buildium. We are working to resolve this as soon as possible.
Posted Feb 03, 2025 - 13:17 EST
This incident affected: Buildium Platform (Buildium Platform).