Site Slowness
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Oct 01, 2020 - 15:32 EDT
Monitoring
We have resolved the issue with slowness in Buildium. We will continue to monitor system performance to ensure the issue is fully resolved.
Posted Oct 01, 2020 - 14:21 EDT
Identified
We have identified the cause of the slowness, and are preparing to release a fix.
Posted Oct 01, 2020 - 11:22 EDT
Investigating
You may be experiencing slowness in Buildium. Our developers are investigating, and we expect any slow performance to be resolved shortly.
Posted Oct 01, 2020 - 10:32 EDT
This incident affected: Buildium Platform.