Site Slowness
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Nov 11, 2020 - 13:33 EST
Monitoring
We have resolved the issue with slowness in Buildium. We will continue to monitor system performance to ensure the issue is fully resolved.
Posted Nov 10, 2020 - 17:04 EST
Investigating
You may be experiencing slowness in Buildium. We expect any slow performance to be resolved soon.
Posted Nov 10, 2020 - 14:21 EST
This incident affected: Buildium Platform.