Buildium Slowness

Incident Report for Buildium

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 18:02 EDT

Monitoring

Slowness has been mitigated, and we are currently monitoring for any further issues.
Posted Apr 09, 2025 - 16:41 EDT

Update

We are continuing to investigate this issue.
Posted Apr 09, 2025 - 15:45 EDT

Investigating

You may be experiencing slowness in Buildium. We are working to resolve this as soon as possible.
Posted Apr 09, 2025 - 15:37 EDT
This incident affected: Buildium Platform (Buildium Platform, Open API).