Intermittent Issues Using Phone Support
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 20:00 EST
Monitoring
Our telephone support vendor believes they have resolved this issue. We will continue to monitor phone performance for additional errors.
Posted Jan 13, 2021 - 19:04 EST
Identified
Our telephone support vendor is currently experiencing intermittent issues with connectivity. If you are unable to connect to a Customer Care Agent, please reach out via a support case. You can submit a case by navigating to settings in the upper right hand corner, and selecting "Contact Support".
Posted Jan 13, 2021 - 17:21 EST
This incident affected: Phone support.