Experiencing issues with our phone system
Incident Report for Buildium
Resolved
The issue has been fully resolved by our phone support provider.
Posted Sep 20, 2021 - 13:10 EDT
Monitoring
We are seeing recovery to the phone systems. We will continue to monitor the situation.
Posted Sep 20, 2021 - 12:38 EDT
Update
Update - We are able to observe some improvements, but some delay assigning Inbound calls to agents might still be noticed currently for a subset of customers.
Posted Sep 20, 2021 - 12:02 EDT
Update
Update - We are continuing to work on a fix for our support phone issue. We will provide an update as soon as we have more details.
Posted Sep 20, 2021 - 11:45 EDT
Identified
The issue has been identified. Mitigation steps are in progress. We will provide an update as soon as we have more details.
Posted Sep 20, 2021 - 11:07 EDT
Investigating
Notice: We are currently experiencing issues with our phone system Provider. Please submit a support ticket by emailing ticketsupport@buildium.com. We are actively working on a solution, thank you for your patience.
Posted Sep 20, 2021 - 11:02 EDT
This incident affected: Phone support.