Buildium performance issue
Incident Report for Buildium
Resolved
We're happy to report that all issues are resolved. Thank you for your patience.
Posted 13 days ago. Nov 05, 2018 - 14:29 EST
Monitoring
We have resolved the slow load times, and are now monitoring this issue.
Posted 13 days ago. Nov 05, 2018 - 13:24 EST
Update
We are continuing to investigate the issue of slowness in Buildium accounts.
Posted 13 days ago. Nov 05, 2018 - 12:41 EST
Investigating
Buildium is currently experiencing some performance issues that may have impacted your ability to load pages in your account. Our developers are aware and are investigating this issue.
Posted 13 days ago. Nov 05, 2018 - 12:40 EST
This incident affected: Phone support.