Application Slowness
Incident Report for Buildium
Resolved
Maintenance has been completed, and we are happy to report that any slowness you may have experienced has been resolved. Thank you for your patience.
Posted Oct 31, 2019 - 13:05 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 31, 2019 - 13:05 EDT
Identified
You may experience slowness in Buildium due to maintenance. We expect any slow performance to be resolved within the hour.
Posted Oct 31, 2019 - 11:25 EDT
This incident affected: Phone support.