Intermittent login issues
Incident Report for Buildium
Resolved
We're happy to report that all issues are resolved. Thank you again for your patience.
Posted about 2 years ago. Sep 28, 2017 - 14:02 EDT
Monitoring
All issues should now be resolved and all systems are now fully back online. We will monitor system health and will share another update in one hour.
Posted about 2 years ago. Sep 28, 2017 - 13:02 EDT
Investigating
Buildium is currently experiencing intermittent issues with logging in. A viable workaround is to edit the URL to be formatted as such: https://yourcompanyURL.managebuilding.com/Manager/Properties/RentalProperties.aspx

We are still working on this issue and will update this status accordingly
Posted about 2 years ago. Sep 28, 2017 - 12:17 EDT