Subsystems Basic and Premium Tenant Screening services are down
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Feb 06, 2020 - 07:08 EST
Identified
Buildium is currently experiencing a temporary disruption in our Basic and Premium Tenant Screening services. We're sorry for any inconvenience. We are working on a fast resolution and expect these services to be available soon. Thank you for your patience.
Posted Feb 05, 2020 - 19:26 EST