Site Slowness
Incident Report for Buildium
Resolved
This incident has been resolved.
Posted Dec 07, 2020 - 18:09 EST
Update
We have resolved the issue with slowness in Buildium. We will continue to monitor system performance to ensure the issue is fully resolved.
Posted Dec 07, 2020 - 16:56 EST
Update
You may be experiencing slowness in Buildium. Our developers are investigating.
Posted Dec 07, 2020 - 15:22 EST
Monitoring
We have resolved the issue with slowness in Buildium. We will continue to monitor system performance to ensure the issue is fully resolved.
Posted Dec 07, 2020 - 14:15 EST
Investigating
You may be experiencing slowness in Buildium. Our developers are investigating, and we expect any slow performance to be resolved shortly.
Posted Dec 07, 2020 - 12:39 EST
This incident affected: Manager.